Description:

Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List that extends from the specified index to the last element.

Syntax:
public int FindIndex(
int startIndex,
int count,
Predicate<T> match
)
Parameters:
  • startIndex
  • Type: int
  • The zero-based starting index of the search.
  • count
  • Type: int
  • The number of elements in the section to search.
  • match
  • Type: Predicate<T>
  • The Predicate(T) delegate that defines the conditions of the element to search for.
Returns:
Type: int
The zero-based index of the first occurrence of an element that matches the conditions defined by match, if found; otherwise, -1.

Description:

Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List.

Syntax:
public int FindIndex(
int startIndex,
Predicate<T> match
)
Parameters:
  • startIndex
  • Type: int
  • The zero-based starting index of the search.
  • match
  • Type: Predicate<T>
  • The Predicate(T) delegate that defines the conditions of the element to search for.
Returns:
Type: int
The zero-based index of the first occurrence of an element that matches the conditions defined by match, if found; otherwise, -1.

Description:

Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List.

Syntax:
public int FindIndex(
Predicate<T> match
)
Parameters:
  • match
  • Type: Predicate<T>
  • The Predicate(T) delegate that defines the conditions of the element to search for.
Returns:
Type: int
The zero-based index of the first occurrence of an element that matches the conditions defined by match, if found; otherwise, -1.

Nothing found